martes, marzo 30, 2004

Medidas anti-spam

Ayer me planteé en serio (gracias a quejas de algunos clientes) mejorar nuestro filtro antispam. Tenemos montado un Mimedefang para el filtrado de virus y de spam (a través de SpamAssassin).

Me di cuenta de que, a pesar de que le dije que lo hiciera, el soporte de SpamAssassin de Razor no estaba siendo utilizado. Ejecuté un filtrado "manual" de SpamAssassin, para debuguear, y en ese momento Razor empezó a utilizarse...

Además, activé las AWL (autowhitelists) que memorizan puntuaciones anteriores respecto a remitente y máquina de la que procede el envío. De esta manera, si un remitente ha enviado un mensaje con puntuación alta (spam), el siguiente mensaje que envía se supone con una gran predisposición a ser Spam...

Tras esto (que funciona de maravilla, según he visto después), para hacer una prueba se me ocurrió enviarme la prueba de Spam GTUBE... Craso error, porque a partir de ese momento fui considerado
un Spammer bestial (SpamAssassin le da a la prueba de Spam GTUBE una puntuación de 1000 !!), y se filtraban todos mis correos... Tras un reseteo de las AWL todo volvió a la normalidad.

Las medidas parecen que han funcionado... Estamos bloqueando una gran cantidad de Spam, y señalando mensajes que parecen spam, pero para los que no existe demasiada seguridad.

Sólo me ha llegado, desde ayer a las 15:00, un spam que ha pasado el filtro. Ese mensaje ya no llegaría, ya que he aumentado la puntuación que se les da a los mensajes que se encuentren en la base
de datos de Pyzor o Razor2...

Muerte al Spam!!





Publicar un comentario en la entrada